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See	Understanding	Techniques	for	Successful	WCAG	criteria	For	important	information	on	the	use	of	these	information	techniques	and	the	way	in	which	regulatory	WCAG	2.0	success	criteria	are	referred	to.	The	applicability	section	explains	the	scope	of	the	technique	and	the	presence	of	techniques	for	a	specific	technology	does	not	imply	that
technology	can	be	used	in	all	situations	to	create	content	that	meet	the	PDF	documents	WCAG	2.0.tagged	with	modules.	This	technique	refers	to:	see	the	user	agent	support	notes	for	PDF15.	See	also	PDF	Technology	Notes.	Description	The	goal	of	this	technique	is	to	provide	a	mechanism	that	allows	users	to	explicitly	request	a	change	of	context
using	the	sending	action	in	a	PDF	module.	The	expected	use	of	a	send	button	is	to	generate	an	HTTP	request	that	sends	the	data	entered	in	a	module,	then	it	is	an	appropriate	control	to	use	to	cause	a	change	of	context.	In	PDF	documents,	the	sending	buttons	are	normally	implemented	using	a	tool	for	PDF	authoring.	Examples	1	and	2	Demonstrate
how	to	add	a	send	button	using	specific	Authoring	tools.	There	are	other	PDF	tools	that	perform	similar	functions.	Check	the	functionality	provided	by	the	Authoring	PDF	tools	that	provide	accessibility	support.	This	example	is	displayed	with	Adobe	Acrobat	Pro.	There	are	other	software	tools	that	perform	similar	functions.	See	the	list	of	other
software	tools	in	Authoring	PDF	tools	that	provide	accessibility	support.	From	the	toolbar,	select	Forms>	Tool	module>	Button	and	create	a	button	on	the	module.	Log	in	to	the	shortcut	menu	for	the	button	and	select	Property	...	To	open	the	Property	button	dialog	box.	On	the	General	tab,	provide	a	suggestion	for	the	button.	On	the	Options	tab,
choose	an	option	in	the	Layout	menu	for	the	button	label,	the	icon's	image	or	both.	Then,	type	the	text	in	the	label	box	to	identify	the	button	as	a	send	button	and	/	or	click	Choose	Icon	and	locate	the	image	file	you	want	to	use.	On	the	Actions	tab:	to	select	the	trigger,	select	the	mouse	up.	(The	mouse	up	event	is	the	accessible	keyboard	and,	moreover,
ensures	that	the	button	will	not	be	changed	the	context	unexpectedly,	as	it	could	with,	for	example	a	mouse	input	event.)	To	select	Action,	select	Send	a	form.	Click	Add.	In	the	Add	dialog	box,	enter	a	URL	to	collect	data	on	a	server	or	collect	module	data	as	e-mail	attachments.	The	following	image	shows	the	Options	tab	in	the	Property	button	dialog
box.	The	following	image	shows	the	Actions	tab	in	the	Properties	dialog	box.	This	example	is	shown	with	Adobe	LiveCycle	Designer.	There	are	others	software	performing	similar	functions.	See	the	list	of	other	software	tools	in	PDF	authoring	tools	that	provide	accessibility	support.	In	the	Insert>	Standard	menu,	select	the	entry	of	the	HTTP	submit
button.	On	the	object	pane	for	the	HTTP	send	button,	enter	the	URL	for	processing	the	form	submission.	The	following	image	shows	the	standard	menu	with	the	list	of	module	controls.	The	following	image	shows	the	object	pane	with	the	URL	and	other	fields	for	the	appearance	of	the	button.	The	JavaScript	Code	illustrates	the	use	of	a	script	to	specify
the	sending	action.	To	add	this	script	to	the	module	range:	Open	the	Properties	dialog	box,	as	shown	in	Example	1	and	select	the	Actions	tab	Select	execute	a	JavaScript	from	the	drop-down	list	and	select	the	Add	button	Enter	the	JavaScript	code	in	the	window	of	JavaScript	Editor	Dialogue,	for	example:	Var	Asubmitfields	=	New	Array	("Name",	"ID",
"Juser");	This.Submitform	({Curl:	"	,	afturies:	asubmitfields,	csubmitas:	"fdf"	//	i	default,	unnecessary	here});	The	following	images	illustrate	this	process:	This	example	is	shown	in	the	operating	example	adding	a	script	action	to	a	send	button	.Resources	for	each	page	that	sends	a	form,	visually	check	that	the	module	contains	a	button	to	send	and
control	one	of	the	following:	tab	to	the	button	and	verify	that	it	includes	the	module	in	response	to	the	user	action	to	select	the	button.	Open	the	PDF	document	with	a	tool	that	is	able	to	show	the	entitle	action	and	verify	that	the	button	action	is	to	send	the	form.	#	1	is	true	for	each	page	that	contains	a	module.	If	this	is	a	sufficient	technique	for	a
successful	criterion,	the	failure	of	this	test	procedure	does	not	necessarily	mean	that	the	success	criterion	has	not	been	satisfied	in	some	other	way,	only	that	this	technique	has	not	been	implemented	successfully	and	not	It	can	be	used	to	request	compliance.	If	you	have	played	in	the	previous	posts,	you	have	learned	how	to	start	how	to	start	with	a
module	created	in	Microsoft	Word,	convert	it	to	Adobe	Acrobat	PDF,	then	recognize	the	fields	so	that	people	can	use	your	computer	to	enter	data	in	the	form	and	then	save	the	results.	Those	advice	alone	should	save	a	lot	of	work.	But	what	happens	if	we	could	give	the	person	to	fill	out	the	form	a	way	to	send	it	to	you,	preferably	by	e-mail?	It	would
now	be	a	winning	solution.	As	we	are,	we	also	go	to	add	a	reset	button	if	they	are	needed	to	change	the	information	you	already	enter	and	a	convenient	print	button.	You	can	download	the	sample	file	from	this	website	or	you	can	use	a	form	you	have	created	on	your	system.	Just	remember	that	if	you	followed	the	previous	post	to	create	an	enabled
version	of	your	module	reader	you	don't	want	to	use	that	version	for	this	exercise.	Adding	a	send	button	in	Acrobat	Pro	Expand	the	Tools	panel	(if	necessary)	or	click	Tools	at	the	top	of	the	window.	Click	Prepaire	Module.	Click	the	button	icon	in	the	module	toolbar.	Click	the	mouse	where	you	want	to	view	the	button.	Click	All	properties	in	the	pop-up
box.	Click	on	the	General	tab	if	necessary.	Insert	Send	as	the	button	name	and	ToolTip.	Click	the	Options	tab.	Insert	send	as	a	label.	Click	the	Actions	tab.	Choose	a	form	in	the	drop-down	menu	next	to	Select	Action.	Click	Add.	Enter	the	mailto	text:	followed	by	your	email	address	as	a	URL	for	this	link.	I.E.	mailto:	christopher@example.com	Set	the
export	format	to	PDF	the	complete	document.	Sets	the	selection	of	the	field	to	all	of	all	Click	OK.	Click	Close.	Press	Ctrl	+	S	to	save	your	work.	Adding	a	restore	button	Click	the	button	icon	in	the	toolbar	of	the	form.	Click	your	mouse	to	the	left	of	the	submit	button.	Click	All	Properties	in	the	pop-up	box.	Click	the	General	tab	if	necessary.	Enter	the
reset	module	as	button	name	and	tooltip.	Click	the	Options	tab.	Enter	the	recovery	form	as	a	label.	Click	the	Actions	tab.	Choose	Restore	a	module	from	the	drop-down	menu	next	to	selecting	Action.	Click	Add.	Confirm	that	all	form	fields	have	checkboxes	next	to	them	in	the	dialog,	then	click	OK.	Click	Close.	Press	Ctrl	+	S	to	save	your	work.	Adding	a
print	button	Click	the	button	icon	in	the	form	toolbar.	Click	the	mouse	to	the	right	of	the	submit	button.	Click	All	Properties	in	the	pop-up	box.	Click	the	General	tab	if	necessary.	Enter	the	print	form	as	the	button	name	and	tooltip.	Click	the	Options	tab.	Enter	the	print	form	as	the	label.	Click	the	Actions	tab.	Choose	Run	the	menu	item	in	the	drop-
down	menu	next	to	selecting	Action.	Click	Add.	Click	File>	Print	in	the	dialog	box,	then	click	OK.	Click	Close.	Press	Ctrl	+	S	to	save	your	work.	Press	X	to	close	the	Prepare	Form	tool	set.	Experiment	with	your	new	buttons!	If	you	enter	the	settings,	are	the	apps,	apps	and	features	Microsoft	Office	apps	appear	as	installed?	Is	if	so,	uninstall	it	how	could
Acrobat	be	your	default	PDF	value	or	is	it	the	edge?	Would	you	mind	clearing	up	going	to	the	app?	We	use	Windows	10	Pro	laptops	and	Adobe	Acrobat	DC,	along	with	an	Exchange	OS65	Hybrid	Hybrid	email	solution!	But	only	a	handful	of	people	have	the	question.	Sorry,	I	didn’t	see	your	full	answer.	Yes,	the	office	shows	as	installed	and	Acrobat	is	the
default	PDF	viewer.	I	will	try	to	do	a	complete	uninstall\	reinstall	and	see	what	happens.	So	far,	I’ve	only	done	an	online	repair.	Thank	you	for	your	reply!	One	of	our	users	has	the	same	problem.	The	box	is	empty	when	you	click	on	the	email	icon.	No	solution	yet.	I	also	have	the	problem.	Any	help	would	be	appreciated.	I	tried	to	make	a	repair,	but	that
didn’t	help.	I	had	this	problem	on	multiple	computers.	My	users	who	have	this	problem	also	get	that	empty	box	when	they	click	the	Email	button.	I	haven’t	been	able	to	come	up	with	any	whole	solution.	Uninstall,	reboot,	reinstall	worked	for	me.	If	it	reinstalled	before	rebooting	it,	it	didn’t	work.	This	document	explains	how	to	set	action	buttons	in	a
PDF	module	in	Acrobat	DC.Ã¢	(if	you	are	looking	for	more	on	the	properties	of	the	module	fields,	click	the	appropriate	link	above.)	The	buttons	are	most	commonly	associated	with	modules,	but	you	can	add	them	to	any	document.	The	buttons	can	open	a	file,	play	an	audio	or	video	clip,	send	the	data	to	a	Web	server	and	much	more.	When	you	decide
on	how	to	start	an	action,	remember	that	the	buttons	offer	the	following	features	that	links	and	bookmarks	are	not:	a	button	can	activate	a	single	action	or	a	set	of	actions.	A	button	can	change	appearance	in	response	to	mouse	actions.	A	button	can	be	easily	copied	in	many	pages.	Shares	of	the	mouse	Can	CanActions	buttons	different.	For	example,
the	mouse	down	(one	click),	the	mouse	up	(leaving	after	a	click),	insert	the	mouse	(setting	the	pointer	on	the	button)	and	mouse	Â	exit	(setting	the	pointer	away	from	the	button)	It	can	all	start	a	different	action	for	the	button)	same	button.	The	buttons	are	an	easy	and	intuitive	way	to	allow	users	to	start	an	action	in	PDF	documents.	The	buttons	can
have	a	combination	of	labels	and	icons	to	drive	users	through	a	series	of	actions	or	events	by	changing	while	the	mouse	is	moved.	For	example,	you	can	create	buttons	with	â€	œPlay,	â€	"â€"	Lausa,	â€	and	â€	"Etichette	e	â€"	and	appropriate	icons.	Then	you	can	set	the	actions	for	these	buttons	to	play,	pause	and	stop	a	movie	clip.	You	can	select	any
combination	of	mouse	behaviors	for	a	button	and	specify	any	combination	of	actions	for	a	mouse	behavior.	Make	sure	you	are	in	Edit	mode	by	selecting	Tools>	Prepare	the	module,	then	select	the	button	in	the	toolbar.	Your	curser	becomes	a	cross	hair.	On	the	page,	click	where	you	want	to	add	the	button	to	create	a	button	with	the	default	size.	For	a
Custom	Size	button,	drag	a	rectangle	to	define	the	size	of	the	button.	Double-click	the	button	field,	then	specify	a	name,	a	tool	tip	text	and	other	common	properties.	Click	the	Appearance	tab,	then	specify	the	options	to	determine	the	appearance	of	the	button	on	the	page.	Remember,	if	you	select	a	background	color,	you	are	unable	to	see	in	any
image	behind	the	button.	Text	options	affect	the	label	specified	in	the	Options	tab,	not	the	button	name	in	the	General	tab.	Note:	If	you	enable	the	right-left	language	options	is	selected	in	the	international	panel	of	the	Preferences	dialog	box,	the	Appearance	tab	includes	options	to	change	the	digit	style	and	text	direction	for	the	buttons.	Click	the
Options	tab	and	select	Options	to	determine	how	the	labels	and	icons	are	displayed	on	the	button.	Click	the	Actions	tab.	Specify	the	options	to	determine	what	happens	when	you	click	the	button,	such	as	jumping	into	a	different	page	or	playing	a	multimedia	clip.	Note:	If	you	are	creating	a	set	of	buttons,	you	can	click	the	object	on	lines	or	guides	of
the	grid.	To	view	the	preview	and	test	the	button,	click	Preview	at	the	right	end	of	the	toolbar.	Once	finished,	you	can	click	Edit	to	return	to	the	Prepare	Form	tool	or	click	the	Cross	icon	at	the	right	end	of	the	toolbar	to	close	the	tool.	When	you	distribute	a	module,	Acrobat	automatically	controls	the	module.	If	you	don't	find	a	buttonEnter,	add	a
module	send	button	to	the	document	message	bar.	Users	can	click	the	Send	Module	button	to	send	the	modules	completed	to	you.	If	you	are	not	going	to	use	the	Send	Module	button	created	by	Acrobat,	you	can	add	a	custom	emitting	button	to	the	module.	If	you	are	not	in	modification	mode,	select	Tools>	Prepare	the	form.	Using	the	button	tool,	drag
through	the	area	where	you	want	to	view	the	button.	Double-click	the	button	and	set	the	options	in	the	General	Tabs	and	Options.	On	the	Options	tab,	choose	an	option	in	the	Layout	menu	for	the	button	label,	the	icon's	image	or	both.	Do	or	both	of	the	following	options:	Type	the	text	in	the	Label	box	to	identify	the	button	as	the	sending	button.	Click
Choose	icon	and	type	the	location	of	an	image	file	or	click	Browse	and	locate	the	image	file	you	want	to	use.	On	the	Actions	tab,	choose	Send	a	form	in	the	Select	Action	menu,	and	then	click	Add.	In	the	Select	Form	dialog	box,	do	one	of	the	following:	To	collect	the	module	data	on	a	server,	type	the	location	in	the	Insert	a	URL	box	for	this	link.	For
example,	.[domain]/[folder]/[subfolder]/	for	an	Internet	address	or	\\[server]\[folder]\	for	a	location	on	a	local	network.	To	collect	the	form	data	as	attachments	to	the	email,	type	in	email:	followed	by	the	email	address.	For	example,	emailto:nobody@adobe.com.	Select	options	for	Export	Format,	Field	Selection	and	Date	Options,	and	click	OK.	To
preview	and	test	the	button,	click	Preview	at	the	right	end	of	the	toolbar.	Once	done,	you	can	click	Edit	to	return	to	the	Preparation	Form	tool,	or	click	the	cross-shaped	icon	at	the	right	end	of	the	toolbar	to	close	the	tool.	Note:	If	the	data	is	returned	in	FDF	or	XFDF	format,	the	server	URL	must	end	with	the	suffix	#FDF,	such	as	.	The	following
options	are	available	in	the	Send	Selects	dialog	box:	Enter	a	URL	for	this	linkSpecify	the	URL	for	the	module	data	collection.	Returns	user	input	without	sending	back	the	underlying	PDF	file.	You	can	select	the	options	to	include	field	data,	comments	and	incremental	changes	to	PDF.	Note:	Selecting	the	option	for	incremental	changes	is	useful	to
receive	digital	signatures	easily	to	read	and	rebuild	from	a	server.	Returns	the	module	to	Hypertext	Markup	Language.	Returns	user	input	as	an	XML	file.	You	can	include	comments	with	field	data	or	only	field	data.	Returns	the	entire	PDF	file	with	user	input.	Specifies	which	fields	are	returned.	To	receive	only	some	of	the	completed	field	data,	select
Only	these,	click	Select	Fields	and	select	which	fields	to	include	or	exclude	in	the	Field	Selection	dialog	box.	For	example,	you	could	use	this	option	to	exclude	certain	calculated	or	duplicated	fields	that	appear	in	the	form	for	the	benefit	of	the	user,	but	that	do	not	add	new	information.	Standardize	the	format	for	the	dates	that	you	enter.	A	button	can
have	a	label,	icon	or	both.	You	can	change	the	way	the	button	appears	in	each	mouse	state	(Up,	Down	and	Rollover).	For	example,	you	could	create	a	button	with	a	“Home”	label	until	the	pointer	does	notmoved	to	the	button,	when	it	might	have	a	label	“Click	to	return	to	the	home	page”.	You	can	create	buttons	icons	from	any	file	format	displayed	by
Acrobat,	including	PDF,	JPEG,	GIF	and	other	image	formats.	For	any	format	you	choose,	the	entire	page	is	used,	so	if	you	want	to	use	only	a	part	of	a	page	as	an	icon,	you	need	to	crop	the	image	or	page	before	you	do	this.	The	smallest	allowed	size	of	the	PDF	page	is	1-by-1	inch	(2,54-by-2,54	cm).	If	you	want...	you	want..	.Icon	to	appear	smaller	than
1-by-1	inches,	scaling	to	fit	the	box	sizes	drawn	with	the	button.	Click	Advanced	on	the	Options	tab	of	the	Property	Button	dialog	box	allows	you	to	determine	how	a	button	icon	is	climb	to	fit	inside	a	button.	A.	Label	only	B.	Icon	Only	C.	Top	icon,	lower	label	D.	Upper	label,	lower	icon	E.	Left	icon,	right	label	F.	Left	label,	Right	icon	G.	Label	above	icon
If	you	do	not	in	edit	mode	of	the	module,	choose	Tools>	Prepare	the	form.	Select	the	button	field,	and	then	do	one	of	the	following:	To	change	the	properties	for	the	button,	double-click	the	button.	To	change	the	appearance	of	the	buttons,	use	the	appearance	options	on	the	Appearance	tab	of	the	Property	button	dialog	box.	To	align,	center	or
distribute	the	button	with	other	shape	fields,	or	to	resize	or	duplicate	the	button,	right-click,	then	choose	an	option	from	the	shortcut	menu.	Close	all	open	dialog	windows	if	necessary.	Click	the	Cross	icon	at	the	right	end	of	the	preparation	form	toolbar	to	close	the	instrument.	If	you	are	not	in	modification	modification	mode,	choose	Tools>	Prepare
the	form.	Double-click	an	existing	button,	and	then	click	the	Options	tab	in	the	Property	button	dialog	box.	For	layout,	choose	the	type	of	display	of	the	label	you	want.	(For	information	on	the	scaling	button	icons,	see	the	next	procedure.)	For	Behavior,	specify	the	display	of	the	button	when	clicked.	To	define	the	label	or	icon	that	appears	on	the
button,	do	the	following:	If	a	label	option	is	selected	from	the	Layout	menu,	type	the	text	in	the	Label	box.	If	an	icon	option	is	selected	from	the	Layout	menu,	click	Choose	Icon,	click	Browse	and	select	the	file.	(Click	clear	to	remove	the	selected	icon.)	Close	all	open	dialog	boxes,	if	necessary.	Click	the	Cross	icon	at	the	right	end	of	the	preparation	form
toolbar	to	close	the	instrument.	It	maintains	the	appearance	of	the	button	itself.	Specifies	the	appearances	for	the	states	up,	down	and	rollover	of	the	mouse.	Select	a	status	option,	then	specify	a	label	or	icon	option:	Determines	how	the	button	appears	when	the	mouse	button	is	not	clicked.	Determines	how	the	button	appears	when	the	mouse	is
clicked	on	the	button,	but	before	it	is	released.	Determines	how	the	button	appears	when	the	pointer	is	held	above	the	button.	Highlight	the	border	of	the	button.	Invert	dark	and	clear	button	shades.	If	you	are	not	in	modification	modification	mode,	choose	Tools>	Prepare	the	form.	Double-click	an	existing	button	to	open	the	button	Properties	dialog.
Click	the	Options	tab,	select	one	of	the	icon	options	from	the	Layout	menu,	and	then	click	Advanced.	Note:	The	Advanced	button	is	not	available	if	you	choose	Label	only	from	the	Layout	menu.	Select	an	option	from	the	When	to	scale	menu:	Scale	the	icon	as	defined	regardless	of	its	size	relative	to	the	size	of	the	button.	Retains	the	original	size	of	the
icon;	the	button	edge	trims	the	icon	if	it	doesn’t	fit.	If	it	is	never	selected,	scale	options	are	not	available.	Scale	icon	as	defined	only	It's	bigger	than	the	button.	Stairs	the	icon	as	defined	only	if	it	is	smaller	than	the	button.	From	the	Scale	menu,	select	whether	to	scale	the	icon	in	proportion.	If	the	icon	is	climbing	not	proportionally,	it	can	be	sewn.	To
make	sure	the	sides	up	and	down	or	left	and	to	the	right	of	the	icon	are	flush	against	the	borders	of	the	button,	select	Fit	to	Bounds.	To	define	where	the	icon	is	positioned	inside	the	button,	drag	the	cursor	arrows.	The	positioning	of	the	icon	is	defined	based	on	the	percentage	of	space	stored	between	the	icon	and	the	left	field	limit,	and	between	the
icon	and	the	lower	field	limit.	The	default	setting	(50,	50)	positions	the	icon	in	the	middle	of	a	field.	You	can	click	Restore	at	any	time	to	return	to	the	default	setting.	Click	OK	and	then	click	Close.	To	preview	and	test	the	button,	click	Preview	at	the	right	end	of	the	toolbar.	Once	done,	you	can	click	Edit	to	return	to	the	Preparation	Form	tool,	or	click
the	Cross	icon	at	the	right	end	of	the	toolbar	to	close	the	instrument.	In	some	cases,	you	can	wish	that	the	button	area	is	invisible	until	the	pointer	moves	above	it.	Showing	and	hiding	a	button,	you	can	create	interesting	visual	effects	in	a	document.	For	example,	when	you	move	a	pointer	to	a	city	on	a	map,	a	detailed	map	of	the	city	could	be	viewed,
and	the	detailed	map	may	disappear	when	the	pointer	moves	away	from	the	city.	Showing	and	hiding	Icons	A.	Pointer	not	above	the	button	B	button.	Pointer	Enter	the	button	C.	Pointer	Exit	button	area	If	you	do	not	in	modify	module	mode,	choose	Tools>	Prepare	the	form.	Using	the	button	tool,	drag	through	the	area	where	you	want	to	view	the	pop-
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